HTML <input> required Attribute

With required Attribute

OS Browser Screen Reader Results
OSX Yosemite 10.10.5 Safari Version 9.1.2 (10601.7.7) VoiceOver Utility Version 7.0 (390.104) VoiceOver announces the words "required invalid data"
Windows 7 FireFox NVDA NVDA announces the works "invalid entry edit autocomplete"

Without required Attribute

With required Attribute and aria-required="true"

Only aria-required="true"